Versão atual:

Algoritimo matriz quadrada

Bom dia pessoal, estou fazendo analise e des, sistemas e tenho seguinte exercicio:

Uma matriz quadrada é dita simétrica se para todo i e j, o elemento (i, j) é sempre igual ao elemento (j,i). Escrever um subalgoritmo que verifica se uma matriz é ou não simétrica.

Bom eu fiz seguindo a logica certa mais nao importa oque eu coloque sempre da verdadeiro ou sempre da tudo falso.

var



   i,j: inteiro
   A: vetor[1..3,1..3] de inteiro
   res: logico
   inicio

         escreval("Digite valores da matriz")

         para i de 1 ate 3 passo 1 faca
            para j de 1 ate 3 passo 1 faca
             leia(A[i,j])
            fimpara
          fimpara

          para i de 1 ate 3 passo 1 faca
            para j de 3 ate 1 passo 1 faca
                se A[i,j] <> A[j,i] entao
                   res<- falso
                   senao
                        res<- verdadeiro
                fimse

            fimpara
          fimpara

          para i de 1 ate 3 passo 1 faca
            para j de 1 ate 3 passo 1 faca
             escreva(A[i,j]:4)
            fimpara
            escreval("")
          fimpara


        escreva(res)




fimalgoritmo

Versão(1):

Ver a versão formatada

Algoritimo matriz quadrada

  • criado 26 de jun de 2015

Comentário

new question