1. java
  2. android
  3. c#
  4. .net
  5. javascript
  6. php
  7. jquery
  8. html
  9. sql

Algoritimo matriz quadrada

Bom dia pessoal, estou fazendo analise e des, sistemas e tenho seguinte exercicio:

Uma matriz quadrada é dita simétrica se para todo i e j, o elemento (i, j) é sempre igual ao elemento (j,i). Escrever um subalgoritmo que verifica se uma matriz é ou não simétrica.

Bom eu fiz seguindo a logica certa mais nao importa oque eu coloque sempre da verdadeiro ou sempre da tudo falso.

var



   i,j: inteiro
   A: vetor[1..3,1..3] de inteiro
   res: logico
   inicio

         escreval("Digite valores da matriz")

         para i de 1 ate 3 passo 1 faca
            para j de 1 ate 3 passo 1 faca
             leia(A[i,j])
            fimpara
          fimpara

          para i de 1 ate 3 passo 1 faca
            para j de 3 ate 1 passo 1 faca
                se A[i,j] <> A[j,i] entao
                   res<- falso
                   senao
                        res<- verdadeiro
                fimse

            fimpara
          fimpara

          para i de 1 ate 3 passo 1 faca
            para j de 1 ate 3 passo 1 faca
             escreva(A[i,j]:4)
            fimpara
            escreval("")
          fimpara


        escreva(res)




fimalgoritmo
  • Algoritimo se escreve: Algoritmo

    Thomas Teixeira   26 de jun de 2015
  1. Você vai ver essas setas em qualquer página de pergunta. Com elas, você pode dizer se uma pergunta ou uma resposta foram relevantes ou não.
  2. Edite sua pergunta ou resposta caso queira alterar ou adicionar detalhes.
  3. Caso haja alguma dúvida sobre a pergunta, adicione um comentário. O espaço de respostas deve ser utilizado apenas para responder a pergunta.
  4. Se o autor da pergunta marcar uma resposta como solucionada, esta marca aparecerá.
  5. Clique aqui para mais detalhes sobre o funcionamento do GUJ!

1 resposta

Não é a resposta que estava procurando? Procure outras perguntas com as tags java sql php java-ee javafx java8 ou faça a sua própria pergunta.