1. java
  2. android
  3. c#
  4. .net
  5. javascript
  6. php
  7. jquery
  8. html
  9. sql

Algoritmo para converter unidade de medidas computacionais [VISUALG] ?

Olá Pessoal estou criando um algoritmo simples de conversão de medida para uma apresentação do trabalho da disciplina de Algoritmo e Estruturas de Dados Ciclo/Modulo 1A , porem estou com algumas dúvidas como posso fazer uma validação simples no visualg ? se o usuário digitar uma opção invalida por exemplo , alguém sabe como posso implementar isso no visualg ? estava pensando em utilizar o operador Se opção for diferente <> mas no visualg/portugol to apanhando de tao feioso que ele e kkk... Gostaria de uma opinião de vcs sobre este algorítimo o que posso melhorar nele , tentei deixar mais simples possível para que o pessoal da sala entenda a lógica e gostaria de umas dicas para minha apresentação , criticas são bem vindas !!

algoritmo "ConversaodeMedida"
// Função : Conversão de unidades Kb,Mb,Gb,Tb
// Autor : Matheus Gonçalves
// Data : 11/03/2015
// Seção de Declarações
var
opcao  : inteiro
qntatual: real
inicio
// Seção de Comandos
escreval ("Escolha a unidade de medida atual , de acordo com o menu abaixo :")
escreval ("1- KB 2-MB 3-GB -4TB")
leia (opcao)
escreval ("Digite a quantidade :")
leia (qntatual)
// SE OPCAO IGUAL A KB
se (opcao = 1) entao
   // KB > MB > GB> TB
   //valor em Kb
   escreval (qntatual," : kilobyte (kB)")
   // valor em Mb
   escreval  (qntatual/1024," : megabyte (MB)")
   //valor em Gb
   escreval ((qntatual/1024)/1024," : gigabyte (GB)")
   //valor em Tb
   escreval (((qntatual / 1024)/1024)/1024 ," : terabyte (TB)")
senao
   // SE OPCAO IGUAL MB
   se (opcao = 2) entao
      //KB < MB > GB > TB
      // valor em kb
      escreval (qntatual*1024," : kilobyte (kB)")
      // valor em mb
      escreval (qntatual," : megabyte (MB)")
      // valor em gb
      escreval (qntatual/1024 ," : gigabyte (GB)")
      // valor em tb
      escreval (((qntatual /1024)/1024) , " : terabyte (TB)")
   senao
      // SE OPCAO IGUAL GB
      se (opcao = 3 )entao
         //kb < mb < gb > tb
         //valor em kb
         escreval(qntatual*1024*1024, " : kilobyte (kB)")
         //valor em mb
         escreval(qntatual*1024, " : megabyte (MB)")
         //valor em gb
         escreval (qntatual, " : gigabyte (GB)")
         //Valor em Tb
         escreval (qntatual / 1024, " : terabyte (TB)")
      senao
         // SE OPCAO IGUAL TB
         se (opcao = 4 )entao
            //kb < mb < gb < tb
            //valor em kb
            escreval(qntatual*1024*1024*1024 ," Kb")
            //valor em mb
            escreval(qntatual*1024*1024 ," Mb" )
            //valor em gb
            escreval(qntatual*1024," Gb" )
            //Valor em Tb
            escreval(qntatual, " Tb")
         fimse
      fimse
   fimse
fimse
fimalgoritmo
  1. Você vai ver essas setas em qualquer página de pergunta. Com elas, você pode dizer se uma pergunta ou uma resposta foram relevantes ou não.
  2. Edite sua pergunta ou resposta caso queira alterar ou adicionar detalhes.
  3. Caso haja alguma dúvida sobre a pergunta, adicione um comentário. O espaço de respostas deve ser utilizado apenas para responder a pergunta.
  4. Se o autor da pergunta marcar uma resposta como solucionada, esta marca aparecerá.
  5. Clique aqui para mais detalhes sobre o funcionamento do GUJ!

2 respostas

Não é a resposta que estava procurando? Procure outras perguntas com as tags java c# android php .net asp.net-mvc ou faça a sua própria pergunta.