1. java
  2. android
  3. c#
  4. .net
  5. javascript
  6. php
  7. jquery
  8. html
  9. sql

Problema em tempo de execução de servlet Oi Mundo (Hello World) com erro java.lang.ClassNotFoundException

ERRATA Link para post inicial

Como citei no titulo é um servlet Oi mundo (Hello World) com erro em tempo de execução que já tentei solucionar de varias maneiras e sem solução Estou usando Eclipse EE Luna Release e Apache Tomcat 8.0

O programa trata se de um OiMundo servlet

Segue abaixo o link do projeto, o código da OiMundo.classe, do Web.xml e o erro respectivamente:

Link para download do projeto em 4shared

O código OiMundo e Web.xml

Essa postagem esta com o codigo Oi.Mundo.java do Andre

O codigo que havia postado esta no projeto para download

Eu esqueci de usar a função Code Example do editor de pergunta deste forum

E também não conseguir editar o post corretamente do link

Estou corrigindo o post

package br.com.caelum.servlet;

import java.io.IOException;
import java.io.PrintWriter;

import javax.servlet.ServletException;
import javax.servlet.http.HttpServlet;
import javax.servlet.http.HttpServletRequest;
import javax.servlet.http.HttpServletResponse;

@SuppressWarnings("serial")
public class OiMundo extends HttpServlet {
    public void doget(HttpServletRequest request, HttpServletResponse response) throws ServletException, IOException {
        PrintWriter out = response.getWriter();
    out.println("<html>\n" + "<head><title>Oi Mundo</title></head>\n" + "<body>\n" + "<h1>Oi Mundo</h1>\n" + "</body></html>");
    }
}
<?xml version="1.0" encoding="UTF-8"?>
<web-app xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://xmlns.jcp.org/xml/ns/javaee" xsi:schemaLocation="http://xmlns.jcp.org/xml/ns/javaee http://xmlns.jcp.org/xml/ns/javaee/web-app_3_1.xsd" id="WebApp_ID" version="3.1">

    <display-name>OiMundo</display-name>

    <welcome-file-list>
        <welcome-file>index.html</welcome-file>
        <welcome-file>index.htm</welcome-file>
        <welcome-file>index.jsp</welcome-file>
        <welcome-file>default.html</welcome-file>
        <welcome-file>default.htm</welcome-file>
        <welcome-file>default.jsp</welcome-file>
    </welcome-file-list>

    <servlet>
        <servlet-name>OiMundo</servlet-name>
        <servlet-class>br.com.caelum.servlet.OiMundo</servlet-class>
        <load-on-startup>1</load-on-startup>
    </servlet>
    <servlet-mapping>
        <servlet-name>>OiMundo</servlet-name>
        <url-pattern>/</url-pattern>
    </servlet-mapping>
</web-app>

E o seguinte erro:

java.lang.ClassNotFoundException 
 - klass: 'java/lang/ClassNotFoundException'
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  Internal Error (exceptions.cpp:424), pid=4228, tid=7124
#  fatal error: ExceptionMark destructor expects no pending exceptions
#
# JRE version: Java(TM) SE Runtime Environment (7.0_67-b01) (build 1.7.0_67-b01)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (24.65-b04 mixed mode windows-amd64 compressed oops)
# Failed to write core dump. Minidumps are not enabled by default on client versions of Windows
#
# An error report file with more information is saved as:
# C:\Users\Wellington\Desktop\eclipse-jee-luna-R-win32-x86_64\eclipse\hs_err_pid4228.log
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.sun.com/bugreport/crash.jsp
#
  • Não to conseguindo postar o codigo corretamente

    wellingtonmoreno   16 de set de 2014
  • Editei para você. Só para te avisar. Em vez de fazer outra pergunta para a mesma dúvida, você consegue editar a pergunta original para adicionar detalhes ou alterar alguma coisa.

    lucastody   16 de set de 2014
  • Não,fica dando erro de pagina 404, ai tento modificar o post e postar novamente da erro de tags não encontrada

    wellingtonmoreno   16 de set de 2014
  • sabe o que é esquisito? seu metodo deveria se chamar doGet com g maiusculo.

    peczenyj   16 de set de 2014
  • Tanto os código .java meu e do Andre parece correto, sera o problema no web.xml faltando alguma coisa, no Eclipse não exibe erro nenhum no web.xml mas quando executo o projeto da esse erro em execução Pensei que fosse alguma configuração do projeto que mexi Então criei um novo projeto agora e inserir o .java do Andre e modifiquei o web.xml do novo projeto igual ao que consta na postagem Mas continua o erro

    wellingtonmoreno   16 de set de 2014
Mostrar todos os 12 comentários>
  1. Você vai ver essas setas em qualquer página de pergunta. Com elas, você pode dizer se uma pergunta ou uma resposta foram relevantes ou não.
  2. Edite sua pergunta ou resposta caso queira alterar ou adicionar detalhes.
  3. Caso haja alguma dúvida sobre a pergunta, adicione um comentário. O espaço de respostas deve ser utilizado apenas para responder a pergunta.
  4. Se o autor da pergunta marcar uma resposta como solucionada, esta marca aparecerá.
  5. Clique aqui para mais detalhes sobre o funcionamento do GUJ!

0 resposta

Não é a resposta que estava procurando? Procure outras perguntas com as tags servlets web.xml java web java-ee jsf jsp eclipse tomcat ou faça a sua própria pergunta.