1. java
  2. android
  3. c#
  4. .net
  5. javascript
  6. php
  7. jquery
  8. html
  9. sql

Erro de plugin Maven Netbeans

Estou tentando executar um projeto no netbeans e está dando o seguinte erro “org.codehaus.mojo:exec-maven-plugin:1.2.1:exec”. Pesquisei sobre o erro, e encontrei a seguinte solução: botão direito no projeto > propriedades > ações > alterar as ações que contém 1.2.1 para 1.6.0, porém, ao fazer isso o erro continua, agora na versão “org.codehaus.mojo:exec-maven-plugin:1.6.0:exec”.

Arquivo POM:

<?xml version="1.0" encoding="UTF-8"?>
    <project xmlns="http://maven.apache.org/POM/4.0.0"                 
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
    xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 
    http://maven.apache.org/xsd/maven-4.0.0.xsd">
   <modelVersion>4.0.0</modelVersion>
   <groupId>com.mycompany</groupId>
   <artifactId>Mainline</artifactId>
   <version>1.0-SNAPSHOT</version>
   <packaging>jar</packaging>
   <repositories>
       <repository>
    <id>unknown-jars-temp-repo</id>
    <name>A temporary repository created by NetBeans for libraries and jars it could not identify.               
   Please replace the dependencies in this repository with correct ones and delete this repository. 
   </name>
    <url>file:${project.basedir}/lib</url>
    </repository>
   </repositories>
<properties>
<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
<maven.compiler.source>1.8</maven.compiler.source>
<maven.compiler.target>1.8</maven.compiler.target>
</properties>
<dependencies>
<!-- https://mvnrepository.com/artifact/com.github.oshi/oshi-core -->
<dependency>
    <groupId>com.github.oshi</groupId>
    <artifactId>oshi-core</artifactId>
    <version>3.8.0</version>
</dependency>
<dependency>
    <groupId>unknown.binary</groupId>
    <artifactId>AbsoluteLayout</artifactId>
    <version>SNAPSHOT</version>
</dependency>
<dependency>
    <groupId>com.microsoft.sqlserver</groupId>
    <artifactId>mssql-jdbc</artifactId>
    <version>7.0.0.jre10</version>
</dependency>
<dependency>
    <groupId>com.microsoft.sqlserver</groupId>
    <artifactId>mssql-jdbc</artifactId>
    <version>6.4.0.jre8</version>
</dependency>
  • Acho que é importante ter mais detalhes para ficar mais fácil de responder. Tem um plugin aí que está com versão para o jre 10. Que versão do ORE estás usando?

    Antônio Diego da Luz Silva   1 mês atrás
  1. Você vai ver essas setas em qualquer página de pergunta. Com elas, você pode dizer se uma pergunta ou uma resposta foram relevantes ou não.
  2. Edite sua pergunta ou resposta caso queira alterar ou adicionar detalhes.
  3. Caso haja alguma dúvida sobre a pergunta, adicione um comentário. O espaço de respostas deve ser utilizado apenas para responder a pergunta.
  4. Se o autor da pergunta marcar uma resposta como solucionada, esta marca aparecerá.
  5. Clique aqui para mais detalhes sobre o funcionamento do GUJ!

0 resposta

Não é a resposta que estava procurando? Procure outras perguntas com as tags java netbeans ou faça a sua própria pergunta.